use strict;
my $str = 'W1W
BT3
BS5
E1W
B68';
my $regex = qr/^([^\d\n]+).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";