$re = '/(.+?)((?:\s\w+\.){0,}\[{0,}`Тип заканчивания`\]{0,})(.+)/s';
$str = 'SELECT
`Тип заканчивания`,
`Дата ввода` FROM [DeleteMe8$A1:B21]
';
$subst = "$1$2$3 GROUP BY $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;