re = /(.+?)((?:\s\w+\.){0,}\[{0,}`Тип заканчивания`\]{0,})(.+)/
str = 'SELECT
`Тип заканчивания`,
`Дата ввода` FROM [DeleteMe8$A1:B21]
'
subst = '$1$2$3 GROUP BY $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result