# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.+?)((?:\s\w+\.){0,}\[{0,}`Тип заканчивания`\]{0,})(.+)"
test_str = ("SELECT\n"
"`Тип заканчивания`, \n"
"`Дата ввода` FROM [DeleteMe8$A1:B21]\n")
subst = "$1$2$3 GROUP BY $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.