using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)\|{2}.*$";
string substitution = @"$1";
string input = @"a|b|c|d
a|b||c||d
a|b||c|d
|||a|b||c||d ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}