re = /^(.*)\|{2}.*$/m
str = 'a|b|c|d
a|b||c||d
a|b||c|d
|||a|b||c||d '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result