$re = '/^(.*)\|{2}.*$/m';
$str = 'a|b|c|d
a|b||c||d
a|b||c|d
|||a|b||c||d ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;