using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9]).{7,}$";
string input = @"PÜaй1212121211221!
йййййййй11111222!x
Ppeepeee12ssxxxaa
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}