re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9]).{7,}$/m
str = 'PÜaй1212121211221!
йййййййй11111222!x
Ppeepeee12ssxxxaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end