$re = '/^[\p{L}\p{Mn}\p{Pd}\'\x{2019}]+(\s[\p{L}\p{Mn}\p{Pd}\'\x{2019}]+)+$/m';
$str = 'Nguyễn hồng Hảo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);