// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\p{L}\p{Mn}\p{Pd}\'\x{2019}]+(\s[\p{L}\p{Mn}\p{Pd}\'\x{2019}]+)+$").unwrap();
let string = "Nguyễn hồng Hảo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}