re = /^[\p{L}\p{Mn}\p{Pd}\'\x{2019}]+(\s[\p{L}\p{Mn}\p{Pd}\'\x{2019}]+)+$/m
str = 'Nguyễn hồng Hảo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end