import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(<img)(?=((?:[^>\"']|\"[^\"]*\"|'[^']*')*?\\s)(src\\s*=\\s*(['\"])\\/mycms\\/~\\/media\\/([a-f0-9]{32})\\.ashx\\4)((?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|[^>]*?)+>))\\s+(?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|[^>]*?)+>";
final String string = "<a hello world href=\"/mycms/~/link.aspx?_id=D9423CEFED254610A5DC6B096A297E17&_z=z\" class>\n"
+ "...\n"
+ "</a>\n\n"
+ "<img hello world src=\"/mycms/~/media/B1FB91AC357347BD84913D56B8791D03.ashx\" alt=\"\" width=\"690\" height=\"202\" />\n\n";
final String subst = "$1$2src='NEWID:key{$5}'$6";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}