const regex = /(.*,.*|\..*)(*SKIP)(*F)|\B(?=(\d{3})+\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*,.*|\\..*)(*SKIP)(*F)|\\B(?=(\\d{3})+\\b)', 'g')
const str = `123
.123456
12.12345
123.12345
1234.1234
7777777
111111.1 5555555555555555
65432.123456
123456789
12345.
12312312312312345.123456789
123,456
1234,456789
12,345,678.12`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);