$re = '/^(\d{1,3},)*(\d{1,3})(\.\d{1,3})?$/m';
$str = '1,478.25
1,450
48.10
145.124.14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);