#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S*rgo1\S*\.html"
Local $sString = "file.html test string something filergo1something.html" & @CRLF & _
"" & @CRLF & _
"ergo1.html some more text" & @CRLF & _
"rgo1.html" & @CRLF & _
"fileergo1.html" & @CRLF & _
"file.html" & @CRLF & _
"test text f_ergo1-ss.html test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")