using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*rgo1\S*\.html";
string input = @"file.html test string something filergo1something.html
ergo1.html some more text
rgo1.html
fileergo1.html
file.html
test text f_ergo1-ss.html test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}