// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S*rgo1\S*\.html").unwrap();
let string = "file.html test string something filergo1something.html
ergo1.html some more text
rgo1.html
fileergo1.html
file.html
test text f_ergo1-ss.html test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}