# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^https?:\\/\\/www\.dropbox\.com)(\\/s\\/\w+\\/[\wа-яА-Яё]+\.\w+).*/https:\/\/dl.dropboxusercontent.com$2/gm;t' <<< "https://www.dropbox.com/s/2f15pra2dssf7zvwf7b/333.jpg?dl=0
https://www.dropbox.com/s/rhdkdf15dykctjdp004/376.jpg?dl=0
https://www.dropbox.com/s/kx70sj1gru4vsawhg9/517.jpg?dl=0"