#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^https?:\/\/www\.dropbox\.com)(\/s\/\w+\/[\wа-яА-Яё]+\.\w+).*"
Local $sString = "https://www.dropbox.com/s/2f15pra2dssf7zvwf7b/333.jpg?dl=0" & @CRLF & _
"https://www.dropbox.com/s/rhdkdf15dykctjdp004/376.jpg?dl=0" & @CRLF & _
"https://www.dropbox.com/s/kx70sj1gru4vsawhg9/517.jpg?dl=0"
Local $sSubst = "https://dl.dropboxusercontent.com$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)