use strict;
my $str = 'https://www.dropbox.com/s/2f15pra2dssf7zvwf7b/333.jpg?dl=0
https://www.dropbox.com/s/rhdkdf15dykctjdp004/376.jpg?dl=0
https://www.dropbox.com/s/kx70sj1gru4vsawhg9/517.jpg?dl=0';
my $regex = qr/(^https?:\/\/www\.dropbox\.com)(\/s\/\w+\/[\wа-яА-Яё]+\.\w+).*/mp;
my $subst = 'https://dl.dropboxusercontent.com$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";