using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)^([^\|]+\|){5}(?<field1>\w+).*\""GET\s+(http|https):\\\\(?<field2>[^\/]+)[^\""]+\""\s+(?<field3>\d+)";
string input = @"<random ip address>|-NA\CAPITA|5xxhxh545|jljdjhsdhj78987|hkjhkdjfkjfd5672v2hg7|87675678vf6x_
<random date time> ""GET http:\\at-abc.com http/1.1"" 500 <random values>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}