$re = '/(?ms)^([^\|]+\|){5}(?<field1>\w+).*\"GET\s+(http|https):\\\\\\\\(?<field2>[^\/]+)[^\"]+\"\s+(?<field3>\d+)/m';
$str = '<random ip address>|-NA\\CAPITA|5xxhxh545|jljdjhsdhj78987|hkjhkdjfkjfd5672v2hg7|87675678vf6x_
<random date time> "GET http:\\\\at-abc.com http/1.1" 500 <random values>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);