package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Pragmatic Store Order Confirmation|There was an error with your payment)`)
var str = `There was an error with your payment`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}