const regex = /(Pragmatic Store Order Confirmation|There was an error with your payment)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Pragmatic Store Order Confirmation|There was an error with your payment)', '')
const str = `There was an error with your payment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}