$re = '/(Pragmatic Store Order Confirmation|There was an error with your payment)/';
$str = 'There was an error with your payment';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);