using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"color\(RGB\((\d+)\,(\d+)\,(\d+)\)\)";
string input = @"color(RGB(11,22,33))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}