#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[Cc](?<![Yy]ellow [Cc])(?<![Bb]lue [Cc])(?<![Rr]ed [Cc])(?<![Pp]urple [Cc])(?<![Bb]lack [Cc])olor"
Local $sString = "Dark Color #match" & @CRLF & _
"light color #match" & @CRLF & _
"Blue Color" & @CRLF & _
"red color" & @CRLF & _
"that is a blue color and theme" & @CRLF & _
"opaque color #match" & @CRLF & _
"purple color"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")