const regex = new RegExp('\\b[Cc](?<![Yy]ellow [Cc])(?<![Bb]lue [Cc])(?<![Rr]ed [Cc])(?<![Pp]urple [Cc])(?<![Bb]lack [Cc])olor', 'gm')
const str = `Dark Color #match
light color #match
Blue Color
red color
that is a blue color and theme
opaque color #match
purple color`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}