#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[Hh ]+[Mm ]+[!-~ ]*$"
Local $sString = "hmm" & @CRLF & _
"Hmmm" & @CRLF & _
"HmmMmm.." & @CRLF & _
"HMMMMMmm" & @CRLF & _
"look behind you" & @CRLF & _
"mmmmmmm" & @CRLF & _
"HMMmmmmm!!!!!" & @CRLF & _
"how odd hmm" & @CRLF & _
"hmmm strange" & @CRLF & _
"hm" & @CRLF & _
"h m m mmm !"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")