// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[Hh ]+[Mm ]+[!-~ ]*$").unwrap();
let string = "hmm
Hmmm
HmmMmm..
HMMMMMmm
look behind you
mmmmmmm
HMMmmmmm!!!!!
how odd hmm
hmmm strange
hm
h m m mmm !";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}