$re = '/^[Hh ]+[Mm ]+[!-~ ]*$/m';
$str = 'hmm
Hmmm
HmmMmm..
HMMMMMmm
look behind you
mmmmmmm
HMMmmmmm!!!!!
how odd hmm
hmmm strange
hm
h m m mmm !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);