#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{2}:\d{2}:\d{2}\.\d+) +--> +(\d{2}:\d{2}:\d{2}\.\d+).*[\r\n]+\s*(?s)((?:(?!\r?\n\r?\n).)*)"
Local $sString = "00:00:02.736 --> 00:00:06.072 line:79.33% position:10.00% align:start " & @CRLF & _
" AND YOUR GRACE?" & @CRLF & _
"" & @CRLF & _
"00:00:06.072 --> 00:00:08.875 line:74.00% position:10.00% align:start " & @CRLF & _
" WHAT WILL YOU DO" & @CRLF & _
" ABOUT THAT?"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)