import re
regex = re.compile(r"(?m)^(\d{2}:\d{2}:\d{2}\.\d+) +--> +(\d{2}:\d{2}:\d{2}\.\d+).*[\r\n]+\s*(?s)((?:(?!\r?\n\r?\n).)*)")
test_str = ("00:00:02.736 --> 00:00:06.072 line:79.33% position:10.00% align:start \n"
" AND YOUR GRACE?\n\n"
"00:00:06.072 --> 00:00:08.875 line:74.00% position:10.00% align:start \n"
" WHAT WILL YOU DO\n"
" ABOUT THAT?")
subst = "|"
result = regex.sub(subst, test_str)
if result:
print(result)