// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.\s?)(\d{2}\s?)(\d{1})(.?\s)(\d{3}.?)(\d{4})$").unwrap();
let string = "+63 2 123 4567
+632 456-7890
+632 4567890
(632) 987 6543";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}