package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/[^\s"'><]+\.php`)
var str = `<img src="/generate-image.php">
<img src="http://www.example.com/external.php">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}