$re = '/\/[^\s"\'><]+\.php/m';
$str = '<img src="/generate-image.php">
<img src="http://www.example.com/external.php">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);