re = /\/[^\s"'><]+\.php/m
str = '<img src="/generate-image.php">
<img src="http://www.example.com/external.php">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end