const regex = /(?:(?:[A-Za-z]{3,9}:?:\/\/www\.?)|(?:[A-Za-z]{3,9}:?:\/\/))((?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)(?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*)?/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:[A-Za-z]{3,9}:?:\\\/\\\/www\\.?)|(?:[A-Za-z]{3,9}:?:\\\/\\\/))((?:[-;:&=\\+\\$,\\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\\+\\$,\\w]+@)[A-Za-z0-9.-]+)(?:\\\/[\\+~%\\\/.\\w-_]*)?\\??(?:[-\\+=&;%@.\\w_]*)#?(?:[.\\!\\\/\\\\w]*)?', 'ug')
const str = `https://98rus.ru/fdjkjd
https://www.regex101.com/r/jC6gE4/1
https://www.vk.com/r/jC6gE4/1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}