import re
regex = re.compile(r"(?:(?:[A-Za-z]{3,9}:?:\/\/www\.?)|(?:[A-Za-z]{3,9}:?:\/\/))((?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)(?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*)?", flags=re.UNICODE)
test_str = ("https://98rus.ru/fdjkjd\n"
"https://www.regex101.com/r/jC6gE4/1\n"
"https://www.vk.com/r/jC6gE4/1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")