$re = '/(?:(?:[A-Za-z]{3,9}:?:\/\/www\.?)|(?:[A-Za-z]{3,9}:?:\/\/))((?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)(?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\\\w]*)?/u';
$str = 'https://98rus.ru/fdjkjd
https://www.regex101.com/r/jC6gE4/1
https://www.vk.com/r/jC6gE4/1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);