using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[\d+\]\[\d+\])?";
string input = @"array[1][2]
prefix[23423][23435]
array1[3][3]
array1[3]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}