package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[\d+\]\[\d+\])?`)
var str = `array[1][2]
prefix[23423][23435]
array1[3][3]
array1[3]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}