$re = '/(\[\d+\]\[\d+\])?/';
$str = 'array[1][2]
prefix[23423][23435]
array1[3][3]
array1[3]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);