const regex = /(\d{1,2})h(?:\s?(\d{1,2})m)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2})h(?:\\s?(\\d{1,2})m)?', '')
const str = `8h 20m
7h `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}