import re
regex = re.compile(r"(\d{1,2})h(?:\s?(\d{1,2})m)?")
test_str = ("8h 20m\n"
"7h ")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")