$re = '/(\d{1,2})h(?:\s?(\d{1,2})m)?/';
$str = '8h 20m
7h ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);