import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "for\\s*\\((\\w*\\s+\\w+\\s*\\=\\s*\\d+\\s*)?\\;(\\s*\\w+\\s*\\W+\\d+\\s*)?\\;(\\s*\\w+\\W+)?\\)\\s*\\{[\\S\\s]+?\\}";
final String string = "for (int i=1;i<=10;i++){\n"
+ "System.out.println(i);\n"
+ "}\n\n"
+ "for(;;){\n"
+ "// This is an infinite loop\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}