const regex = /for\s*\((\w*\s+\w+\s*\=\s*\d+\s*)?\;(\s*\w+\s*\W+\d+\s*)?\;(\s*\w+\W+)?\)\s*\{[\S\s]+?\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('for\\s*\\((\\w*\\s+\\w+\\s*\\=\\s*\\d+\\s*)?\\;(\\s*\\w+\\s*\\W+\\d+\\s*)?\\;(\\s*\\w+\\W+)?\\)\\s*\\{[\\S\\s]+?\\}', 'gm')
const str = `for (int i=1;i<=10;i++){
System.out.println(i);
}
for(;;){
// This is an infinite loop
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}