re = /for\s*\((\w*\s+\w+\s*\=\s*\d+\s*)?\;(\s*\w+\s*\W+\d+\s*)?\;(\s*\w+\W+)?\)\s*\{[\S\s]+?\}/m
str = 'for (int i=1;i<=10;i++){
System.out.println(i);
}
for(;;){
// This is an infinite loop
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end